AddEdge Method (Reference, Double, Reference, Double)


Form Add Edge(Reference, Double, Reference, Double) Method

Add an edge to the form, connecting two edges on same/different profile, by a pair of specified edge/param.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void AddEdge(
	Reference startEdgeReference,
	double startParam,
	Reference endEdgeReference,
	double endParam
)

Parameters

startEdgeReference Reference
The geometry reference of start edge
startParam Double
The param on start edge to specify the location.
endEdgeReference Reference
The geometry reference of end edge
endParam Double
The param on end edge to specify the location.
See Also