Item |
Creates a new model line element.
Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)

Parameters
- geometryCurve Curve
- The internal geometry curve for model line.
- sketchPlane SketchPlane
- The sketch plane this new model line resides in.
Return Value
ModelCurveIf successful a new model line element. Otherwise .

Exception | Condition |
---|---|
ArgumentException | Thrown when curve is not in the plane |

Different type of model curve element will be returned according to the type of geometry curve.