NewModelCurve Method


Item Factory Base New Model Curve Method

Creates a new model line element.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public ModelCurve NewModelCurve(
	Curve geometryCurve,
	SketchPlane sketchPlane
)

Parameters

geometryCurve Curve
The internal geometry curve for model line.
sketchPlane SketchPlane
The sketch plane this new model line resides in.

Return Value

ModelCurve
If successful a new model line element. Otherwise .
Exceptions
Exception Condition
ArgumentException Thrown when curve is not in the plane
Remarks
Different type of model curve element will be returned according to the type of geometry curve.
See Also