Edit |
The base class for a scope object that provides special access and limitations related to editing certain elements.

System Object
Autodesk.Revit.DB EditScope
Autodesk.Revit.DB.Architecture TopographyEditScope
Autodesk.Revit.DB SketchEditScope
Autodesk.Revit.DB StairsEditScope
Autodesk.Revit.DB EditScope
Autodesk.Revit.DB.Architecture TopographyEditScope
Autodesk.Revit.DB SketchEditScope
Autodesk.Revit.DB StairsEditScope
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The EditScope type exposes the following members.

Name | Description | |
---|---|---|
![]() | IsActive | Tells if the EditScope is active. In other words, the EditScope has started but not committed/canceled yet. |
![]() | IsPermitted | Tells if the edit scope is permitted to start. |
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. |

Name | Description | |
---|---|---|
![]() | Cancel | Cancels the edit scope. |
![]() | Commit | Finishes the edit scope. |
![]() | Dispose | Releases all resources used by the EditScope |

Derivations of this class provide specific functionality to manage edit modes for specific purposes.