EditScope Class


Edit Scope Class

The base class for a scope object that provides special access and limitations related to editing certain elements.
Inheritance Hierarchy

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class EditScope : IDisposable

The EditScope type exposes the following members.

Properties
Name Description
Public property IsActive Tells if the EditScope is active. In other words, the EditScope has started but not committed/canceled yet.
Public property IsPermitted Tells if the edit scope is permitted to start.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
Name Description
Public method Cancel Cancels the edit scope.
Public method Commit Finishes the edit scope.
Public method Dispose Releases all resources used by the EditScope
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
Remarks
Derivations of this class provide specific functionality to manage edit modes for specific purposes.
See Also