RebarShapeDefinition Class


Rebar Shape Definition Class

A class to assist in defining rebar shapes. A RebarShape element needs exactly one RebarShapeDefinition.
Inheritance Hierarchy

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class RebarShapeDefinition : IDisposable

The RebarShapeDefinition type exposes the following members.

Properties
Name Description
Public property Complete Report whether the shape definition is fully constrained.
Public property IsPlanar Reports whether the shape definition lies within a plane: false if a spiral, true in all other cases.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
Name Description
Public method AddFormulaParameter Add a formula-driven parameter to the shape definition.
Public method AddParameter Add a parameter to the shape definition.
Public method CheckDefaultParameterValues Check that the shape can be solved with the default parameter values.
Public method Dispose Releases all resources used by the RebarShapeDefinition
Public method GetParameterDefaultValue Return the parameter's default value as stored in the definition.
Public method GetParameterFormula Return the parameter's formula, if one is associated with it.
Public method GetParameters Return the Ids of the shared parameters in the Definition.
Public method HasParameter Whether the definition stores the parameter.
Public method RemoveParameter Remove the parameter from the definition.
Public method SetParameterDefaultValue Change the parameter's value as stored in the definition.
Public method SetParameterFormula Associate a formula with the parameter.
Top
Remarks
A RebarShapeDefinition stores a set of Rebar Shape parameters. Each parameter may be associated with:
  • One or more RebarShapeConstraints; or
  • A formula; or
  • Neither of the above.
Each shape instance (Rebar object) will have its own values for these parameters. The RebarShapeDefinition also stores a default value for each parameter, which is ignored if the parameter is associated with a formula.
See Also