Rebar |
A class to assist in defining rebar shapes. A RebarShape element needs exactly one RebarShapeDefinition.

System Object
Autodesk.Revit.DB.Structure RebarShapeDefinition
Autodesk.Revit.DB.Structure RebarShapeDefinitionByArc
Autodesk.Revit.DB.Structure RebarShapeDefinitionBySegments
Autodesk.Revit.DB.Structure RebarShapeDefinition
Autodesk.Revit.DB.Structure RebarShapeDefinitionByArc
Autodesk.Revit.DB.Structure RebarShapeDefinitionBySegments
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The RebarShapeDefinition type exposes the following members.

Name | Description | |
---|---|---|
![]() | Complete | Report whether the shape definition is fully constrained. |
![]() | IsPlanar | Reports whether the shape definition lies within a plane: false if a spiral, true in all other cases. |
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. |

Name | Description | |
---|---|---|
![]() | AddFormulaParameter | Add a formula-driven parameter to the shape definition. |
![]() | AddParameter | Add a parameter to the shape definition. |
![]() | CheckDefaultParameterValues | Check that the shape can be solved with the default parameter values. |
![]() | Dispose | Releases all resources used by the RebarShapeDefinition |
![]() | GetParameterDefaultValue | Return the parameter's default value as stored in the definition. |
![]() | GetParameterFormula | Return the parameter's formula, if one is associated with it. |
![]() | GetParameters | Return the Ids of the shared parameters in the Definition. |
![]() | HasParameter | Whether the definition stores the parameter. |
![]() | RemoveParameter | Remove the parameter from the definition. |
![]() | SetParameterDefaultValue | Change the parameter's value as stored in the definition. |
![]() | SetParameterFormula | Associate a formula with the parameter. |

A RebarShapeDefinition stores a set of Rebar Shape parameters. Each parameter may be associated with:
- One or more RebarShapeConstraints; or
- A formula; or
- Neither of the above.