Compound |
Retrieves the deck embedding type used for the specified structural deck.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- layerIdx Int32
- Index of a layer in the CompoundStructure.
Return Value
StructDeckEmbeddingTypeThe embedding type of the structural deck associated to the specified layer. Invalid if it is not a structural deck.

Exception | Condition |
---|---|
ArgumentOutOfRangeException | The layer index is out of range. |