GetDeckEmbeddingType Method


Compound Structure Get Deck Embedding Type Method

Retrieves the deck embedding type used for the specified structural deck.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public StructDeckEmbeddingType GetDeckEmbeddingType(
	int layerIdx
)

Parameters

layerIdx Int32
Index of a layer in the CompoundStructure. The layer index is zero based. It counts from the exterior of wall and from the top of roofs, floors and ceilings.

Return Value

StructDeckEmbeddingType
The embedding type of the structural deck associated to the specified layer. Invalid if it is not a structural deck.
Exceptions
Exception Condition
ArgumentOutOfRangeException The layer index is out of range.
See Also