Analysis |
Contains markers and text settings for analysis display style element.

System Object
Autodesk.Revit.DB.Analysis AnalysisDisplayMarkersAndTextSettings
Autodesk.Revit.DB.Analysis AnalysisDisplayMarkersAndTextSettings
Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)

The AnalysisDisplayMarkersAndTextSettings type exposes the following members.

Name | Description | |
---|---|---|
![]() | AnalysisDisplayMarkersAndTextSettings | Constructs a default instance of markers and text settings. |
![]() | AnalysisDisplayMarkersAndTextSettings(AnalysisDisplayMarkersAndTextSettings) | Constructs a new copy of the input AnalysisDisplayMarkersAndTextSettings object. |

Name | Description | |
---|---|---|
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. |
![]() | MarkerSize | Size of marker. |
![]() | MarkerType | Type of marker. |
![]() | Rounding | Increment to which numeric values of analysis results are rounded in markers. |
![]() | TextLabelType | Type of diagram text label visualization. |
![]() | TextTypeId | Element id of text associated with the settings. |

Name | Description | |
---|---|---|
![]() | Dispose | Releases all resources used by the AnalysisDisplayMarkersAndTextSettings |
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object ) |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object ) |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object ) |
![]() | IsEqual | Compares two colored surface settings objects. |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object ) |