AnalysisDisplayMarkersAndTextSettings Class


Analysis Display Markers And Text Settings Class

Contains markers and text settings for analysis display style element.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.Analysis AnalysisDisplayMarkersAndTextSettings

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class AnalysisDisplayMarkersAndTextSettings : IDisposable

The AnalysisDisplayMarkersAndTextSettings type exposes the following members.

Constructors
Name Description
Public method AnalysisDisplayMarkersAndTextSettings Constructs a default instance of markers and text settings.
Public method AnalysisDisplayMarkersAndTextSettings(AnalysisDisplayMarkersAndTextSettings) Constructs a new copy of the input AnalysisDisplayMarkersAndTextSettings object.
Top
Properties
Name Description
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property MarkerSize Size of marker.
Public property MarkerType Type of marker.
Public property Rounding Increment to which numeric values of analysis results are rounded in markers.
Public property TextLabelType Type of diagram text label visualization.
Public property TextTypeId Element id of text associated with the settings.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the AnalysisDisplayMarkersAndTextSettings
Public method IsEqual Compares two colored surface settings objects.
Top
Example
// Settings relating to the marker shape and size and the display of values
AnalysisDisplayMarkersAndTextSettings markerSettings = new AnalysisDisplayMarkersAndTextSettings();
markerSettings.MarkerSize = .05;
markerSettings.MarkerType = AnalysisDisplayStyleMarkerType.Triangle;
markerSettings.Rounding = .01;

// Settings relating to the marker color
AnalysisDisplayColorSettings colorSettings = new AnalysisDisplayColorSettings();
colorSettings.MaxColor = new Color(255, 0, 0);
colorSettings.MinColor = new Color(0, 255, 255);

// Settings relating to the legend
AnalysisDisplayLegendSettings legendSettings = new AnalysisDisplayLegendSettings();
legendSettings.Rounding = .01;

// Create the new display style
AnalysisDisplayStyle ads = AnalysisDisplayStyle.CreateAnalysisDisplayStyle(doc, "Markers 1", markerSettings, colorSettings, legendSettings);

// Assign the new display style to the current view
doc.ActiveView.AnalysisDisplayStyleId = ads.Id;
See Also