CreateFromCurvesAndShape Method (Document, RebarShape, RebarBarType, RebarHookType, RebarHookType, Element, XYZ, IList(Curve), RebarHookOrientation, RebarHookOrientation, Double, Double, ElementId, ElementId)


Rebar Create From Curves And Shape(Document, Rebar Shape, Rebar Bar Type, Rebar Hook Type, Rebar Hook Type, Element, XYZ, IList Curve , Rebar Hook Orientation, Rebar Hook Orientation, Double, Double, Element Id, Element Id) Method


Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public static Rebar CreateFromCurvesAndShape(
	Document doc,
	RebarShape rebarShape,
	RebarBarType barType,
	RebarHookType startHook,
	RebarHookType endHook,
	Element host,
	XYZ norm,
	IList<Curve> curves,
	RebarHookOrientation startHookOrient,
	RebarHookOrientation endHookOrient,
	double hookRotationAngleAtStart,
	double hookRotationAngleAtEnd,
	ElementId endTreatmentTypeIdAtStart,
	ElementId endTreatmentTypeIdAtEnd
)

Parameters

doc Document
rebarShape RebarShape
barType RebarBarType
startHook RebarHookType
endHook RebarHookType
host Element
norm XYZ
curves IList Curve
startHookOrient RebarHookOrientation
endHookOrient RebarHookOrientation
hookRotationAngleAtStart Double
hookRotationAngleAtEnd Double
endTreatmentTypeIdAtStart ElementId
endTreatmentTypeIdAtEnd ElementId

Return Value

Rebar
See Also