CreateFromCurvesAndShape Method (Document, RebarShape, RebarBarType, RebarHookType, RebarHookType, Element, XYZ, IList(Curve), RebarHookOrientation, RebarHookOrientation, Double, Double, ElementId, ElementId)


Rebar Create From Curves And Shape(Document, Rebar Shape, Rebar Bar Type, Rebar Hook Type, Rebar Hook Type, Element, XYZ, IList Curve , Rebar Hook Orientation, Rebar Hook Orientation, Double, Double, Element Id, Element Id) Method

Note: This API is now obsolete.


Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
[ObsoleteAttribute("This method is deprecated in Revit 2026 and may be removed in a later version of Revit. Please use Rebar.CreateFromCurvesAndShape(Document doc, RebarShape rebarShape, RebarBarType barType, Element host, XYZ norm, IList<Curve> curves, BarTerminationsData barTerminationsData) instead.")]
public static Rebar CreateFromCurvesAndShape(
	Document doc,
	RebarShape rebarShape,
	RebarBarType barType,
	RebarHookType startHook,
	RebarHookType endHook,
	Element host,
	XYZ norm,
	IList<Curve> curves,
	RebarHookOrientation startHookOrient,
	RebarHookOrientation endHookOrient,
	double terminationRotationAngleAtStart,
	double terminationRotationAngleAtEnd,
	ElementId endTreatmentTypeIdAtStart,
	ElementId endTreatmentTypeIdAtEnd
)

Parameters

doc Document
rebarShape RebarShape
barType RebarBarType
startHook RebarHookType
endHook RebarHookType
host Element
norm XYZ
curves IList Curve
startHookOrient RebarHookOrientation
endHookOrient RebarHookOrientation
terminationRotationAngleAtStart Double
terminationRotationAngleAtEnd Double
endTreatmentTypeIdAtStart ElementId
endTreatmentTypeIdAtEnd ElementId

Return Value

Rebar
See Also