CreateFromCurves Method (Document, RebarStyle, RebarBarType, RebarHookType, RebarHookType, Element, XYZ, IList(Curve), RebarHookOrientation, RebarHookOrientation, Double, Double, ElementId, ElementId, Boolean, Boolean)


Rebar Create From Curves(Document, Rebar Style, Rebar Bar Type, Rebar Hook Type, Rebar Hook Type, Element, XYZ, IList Curve , Rebar Hook Orientation, Rebar Hook Orientation, Double, Double, Element Id, Element Id, Boolean, Boolean) Method


Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public static Rebar CreateFromCurves(
	Document doc,
	RebarStyle style,
	RebarBarType barType,
	RebarHookType startHook,
	RebarHookType endHook,
	Element host,
	XYZ norm,
	IList<Curve> curves,
	RebarHookOrientation startHookOrient,
	RebarHookOrientation endHookOrient,
	double hookRotationAngleAtStart,
	double hookRotationAngleAtEnd,
	ElementId endTreatmentTypeIdAtStart,
	ElementId endTreatmentTypeIdAtEnd,
	bool useExistingShapeIfPossible,
	bool createNewShape
)

Parameters

doc Document
style RebarStyle
barType RebarBarType
startHook RebarHookType
endHook RebarHookType
host Element
norm XYZ
curves IList Curve
startHookOrient RebarHookOrientation
endHookOrient RebarHookOrientation
hookRotationAngleAtStart Double
hookRotationAngleAtEnd Double
endTreatmentTypeIdAtStart ElementId
endTreatmentTypeIdAtEnd ElementId
useExistingShapeIfPossible Boolean
createNewShape Boolean

Return Value

Rebar
See Also