Rebar
Create
|
Note: This API is now obsolete.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)

[ObsoleteAttribute("This method is deprecated in Revit 2026 and may be removed in a later version of Revit. Please use Rebar.CreateFromCurves(Document doc, RebarStyle style, RebarBarType barType, Element host, XYZ norm, IList<Curve> curves, BarTerminationsData barTerminationsData, bool useExistingShapeIfPossible, bool createNewShape) instead.")]
public static Rebar CreateFromCurves(
Document doc,
RebarStyle style,
RebarBarType barType,
RebarHookType startHook,
RebarHookType endHook,
Element host,
XYZ norm,
IList<Curve> curves,
RebarHookOrientation startHookOrient,
RebarHookOrientation endHookOrient,
double terminationRotationAngleAtStart,
double terminationRotationAngleAtEnd,
ElementId endTreatmentTypeIdAtStart,
ElementId endTreatmentTypeIdAtEnd,
bool useExistingShapeIfPossible,
bool createNewShape
)
Parameters
- doc Document
- style RebarStyle
- barType RebarBarType
- startHook RebarHookType
- endHook RebarHookType
- host Element
- norm XYZ
- curves IList Curve
- startHookOrient RebarHookOrientation
- endHookOrient RebarHookOrientation
- terminationRotationAngleAtStart Double
- terminationRotationAngleAtEnd Double
- endTreatmentTypeIdAtStart ElementId
- endTreatmentTypeIdAtEnd ElementId
- useExistingShapeIfPossible Boolean
- createNewShape Boolean
Return Value
Rebar