IsAcceptableParamIdAndCategoryId Method (Int32, ElementId, ElementId)


Table Section Data Is Acceptable Param Id And Category Id(Int 32, Element Id, Element Id) Method

Identifies if the given parameter id and category id can be assigned to a cell in the given row in this table.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public bool IsAcceptableParamIdAndCategoryId(
	int nRow,
	ElementId paramId,
	ElementId categoryId
)

Parameters

nRow Int32
row index
paramId ElementId
categoryId ElementId

Return Value

Boolean
True if the ParamId and CategoryId are all valid.
Exceptions
Exception Condition
ArgumentException The given row number nRow is invalid.
ArgumentNullException A non-optional argument was null
See Also