Direct |
This class is used to control behavior of a DirectShape object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The DirectShapeOptions type exposes the following members.

Name | Description | |
---|---|---|
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. |
![]() | ReferencingOption | Whether or not the geometry stored in a DirectShape object may be referenced. |
![]() | RoomBoundingOption | Identifies whether the DirectShape supports an option for the "Room Bounding" parameter to permit participation in room boundary calculations. |

Name | Description | |
---|---|---|
![]() | Dispose | Releases all resources used by the DirectShapeOptions |

Use Enable/Disable functions to change the default behavior. Use DirectShape.SetOptions to modify that object's behavior.