DirectShapeOptions Class


Direct Shape Options Class

This class is used to control behavior of a DirectShape object.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB DirectShapeOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class DirectShapeOptions : IDisposable

The DirectShapeOptions type exposes the following members.

Properties
Name Description
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property ReferencingOption Whether or not the geometry stored in a DirectShape object may be referenced.
Public property RoomBoundingOption Identifies whether the DirectShape supports an option for the "Room Bounding" parameter to permit participation in room boundary calculations.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the DirectShapeOptions
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
Remarks
Use Enable/Disable functions to change the default behavior. Use DirectShape.SetOptions to modify that object's behavior.
See Also