Point |
Define a ReferencePoint relative to a referenceable edge or curve on another element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The PointOnEdge type exposes the following members.

Name | Description | |
---|---|---|
![]() | LocationOnCurve | The point location on curve. |

Name | Description | |
---|---|---|
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object ) |
![]() | GetEdgeReference | Get a copy of the edge or curve reference. |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object ) |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object ) |
![]() | SetEdgeReference | Change the edge or curve reference. |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object ) |

The ReferencePoint's X basis vector is constrained to the tangent vector to the curve. The Y and Z vectors are free to rotate around the curve.