Point |
Define a ReferencePoint relative to a referenceable edge or curve on another element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The PointOnEdge type exposes the following members.

Name | Description | |
---|---|---|
![]() | LocationOnCurve | The point location on curve. |

Name | Description | |
---|---|---|
![]() | GetEdgeReference | Get a copy of the edge or curve reference. |
![]() | SetEdgeReference | Change the edge or curve reference. |

The ReferencePoint's X basis vector is constrained to the tangent vector to the curve. The Y and Z vectors are free to rotate around the curve.