PointOnEdge Class


Point On Edge Class

Define a ReferencePoint relative to a referenceable edge or curve on another element.
Inheritance Hierarchy

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class PointOnEdge : PointElementReference

The PointOnEdge type exposes the following members.

Properties
Name Description
Public property LocationOnCurve The point location on curve.
Top
Methods
Name Description
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetEdgeReference Get a copy of the edge or curve reference.
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method SetEdgeReference Change the edge or curve reference.
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
Remarks
The ReferencePoint's X basis vector is constrained to the tangent vector to the curve. The Y and Z vectors are free to rotate around the curve.
See Also