UpdateExternallyTaggedGeometry Method


Direct Shape Update Externally Tagged Geometry Method

Updates the externally tagged geometry object in the DirectShape.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void UpdateExternallyTaggedGeometry(
	ExternallyTaggedGeometryObject externallyTaggedGeometry
)

Parameters

externallyTaggedGeometry ExternallyTaggedGeometryObject
The externally tagged geometry that should be updated in the DirectShape.
Exceptions
Exception Condition
ArgumentException The input shape does not satisfy DirectShape validation criteria. -or- A previous version of the externally tagged geometry is not present in this DirectShape.
ArgumentNullException A non-optional argument was null
See Also