Point |
Graphic overrides that are stored by a view to be applied to a PointCloudInstance element, or a scan within the element.

Namespace: Autodesk.Revit.DB.PointClouds
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The PointCloudOverrides type exposes the following members.

Name | Description | |
---|---|---|
![]() | PointCloudOverrides | Constructs empty overrides object. |

Name | Description | |
---|---|---|
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. |

Name | Description | |
---|---|---|
![]() ![]() | ArePointCloudOverrideSettingsValid | Checks if PointCloudOverrideSettings are valid |
![]() | Assign | Assigns values of the source overrides to this object. |
![]() | Dispose | Releases all resources used by the PointCloudOverrides |
![]() | GetPointCloudRegionOverrideSettings(ElementId) | Gets region override settings assigned to the whole PointCloudInstance element. |
![]() | GetPointCloudRegionOverrideSettings(ElementId, String, Document) | Gets override settings assigned to a particular region within a PointCloudInstance element. |
![]() | GetPointCloudScanOverrideSettings(ElementId) | Gets scan override settings assigned to the whole PointCloudInstance element. |
![]() | GetPointCloudScanOverrideSettings(ElementId, String, Document) | Gets override settings assigned to a particular scan within a PointCloudInstance element. |
![]() | IsEqual | Check if the contents of two overrides are equal. |
![]() | SetPointCloudRegionOverrideSettings(ElementId, PointCloudOverrideSettings) | Assigns region override settings to the whole PointCloudInstance element. |
![]() | SetPointCloudRegionOverrideSettings(ElementId, PointCloudOverrideSettings, String, Document) | Assigns override settings to a particular region within a PointCloudInstance element. |
![]() | SetPointCloudScanOverrideSettings(ElementId, PointCloudOverrideSettings) | Assigns scan override settings to the whole PointCloudInstance element. |
![]() | SetPointCloudScanOverrideSettings(ElementId, PointCloudOverrideSettings, String, Document) | Assigns scan override settings to a particular scan within a PointCloudInstance element. |