PointCloudOverrides Class


Point Cloud Overrides Class

Graphic overrides that are stored by a view to be applied to a PointCloudInstance element, or a scan within the element.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.PointClouds PointCloudOverrides

Namespace: Autodesk.Revit.DB.PointClouds
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class PointCloudOverrides : IDisposable

The PointCloudOverrides type exposes the following members.

Constructors
Name Description
Public method PointCloudOverrides Constructs empty overrides object.
Top
Properties
Name Description
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
Name Description
Public method Static member ArePointCloudOverrideSettingsValid Checks if PointCloudOverrideSettings are valid
Public method Assign Assigns values of the source overrides to this object.
Public method Dispose Releases all resources used by the PointCloudOverrides
Public method GetPointCloudRegionOverrideSettings(ElementId) Gets region override settings assigned to the whole PointCloudInstance element.
Public method GetPointCloudRegionOverrideSettings(ElementId, String, Document) Gets override settings assigned to a particular region within a PointCloudInstance element.
Public method GetPointCloudScanOverrideSettings(ElementId) Gets scan override settings assigned to the whole PointCloudInstance element.
Public method GetPointCloudScanOverrideSettings(ElementId, String, Document) Gets override settings assigned to a particular scan within a PointCloudInstance element.
Public method IsEqual Check if the contents of two overrides are equal.
Public method SetPointCloudRegionOverrideSettings(ElementId, PointCloudOverrideSettings) Assigns region override settings to the whole PointCloudInstance element.
Public method SetPointCloudRegionOverrideSettings(ElementId, PointCloudOverrideSettings, String, Document) Assigns override settings to a particular region within a PointCloudInstance element.
Public method SetPointCloudScanOverrideSettings(ElementId, PointCloudOverrideSettings) Assigns scan override settings to the whole PointCloudInstance element.
Public method SetPointCloudScanOverrideSettings(ElementId, PointCloudOverrideSettings, String, Document) Assigns scan override settings to a particular scan within a PointCloudInstance element.
Top
See Also