FabricationItemFolder Class


Fabrication Item Folder Class

A fabrication item folder that can contain sub folders and access to the FabricationItemFile s contained within.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB FabricationItemFolder

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class FabricationItemFolder : IDisposable

The FabricationItemFolder type exposes the following members.

Properties
Name Description
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property Name The item folder's name.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the FabricationItemFolder
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetItemFiles Gets the item files in this item folder.
Public method GetSubFolders Gets the item folder's sub folders.
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
See Also