FindMatchingPredefinedPresentationMode Method


Rebar Container Item Find Matching Predefined Presentation Mode Method

Determines if there is a matching RebarPresentationMode for the current set of selected hidden and unhidden bars assigned to the given view.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public RebarPresentationMode FindMatchingPredefinedPresentationMode(
	View dBView
)

Parameters

dBView View
The view.

Return Value

RebarPresentationMode
The presentation mode that matches the current set of selected hidden and unhidden bars. If there is no better match, this returns RebarPresentationMode.Select.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
Remarks
If the presentation mode is not PresentationMode.Select for the view, this function returns the current mode.
See Also