MakeFromPositionAcceptable Method


Spatial Element From To Calculation Points Make From Position Acceptable Method

This function takes a potential "from" point and converts it to be a similar point on the opposite side of the family's host from the "to" point if necessary.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public XYZ MakeFromPositionAcceptable(
	XYZ newFromLocation
)

Parameters

newFromLocation XYZ
The desired "from" location

Return Value

XYZ
The valid "from" location.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
Remarks
If the point is already an acceptable "from" location then the original point will be returned. Otherwise, the point's X and Y will be projected onto the centerline of the family's host.
See Also