Spatial |
This function takes a potential "from" point and converts it to be a similar point on the opposite side of the family's host from the "to" point if necessary.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- newFromLocation XYZ
- The desired "from" location
Return Value
XYZThe valid "from" location.

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |

If the point is already an acceptable "from" location then the original point will be returned. Otherwise, the point's X and Y will be projected onto the centerline of the family's host.