MEPNetwork |
Represents a unique identifier for one analytical segment in the network.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The MEPNetworkSegmentId type exposes the following members.

Name | Description | |
---|---|---|
![]() | MEPNetworkSegmentId | Creates a default invalid segment id on the network. |
![]() | MEPNetworkSegmentId(ElementId, Int32) | Creates a valid segment id on the network. |

Name | Description | |
---|---|---|
![]() | ElementId | The element id where this analytical segment belongs. |
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. |
![]() | SegmentId | The segment identifier. |

Name | Description | |
---|---|---|
![]() | Dispose | Releases all resources used by the MEPNetworkSegmentId |
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object ) |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object ) |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object ) |
![]() | IsValid | Verifies if this is a valid segment id. |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object ) |