MEPNetwork |
Represents a unique identifier for one analytical segment in the network.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The MEPNetworkSegmentId type exposes the following members.

Name | Description | |
---|---|---|
![]() | MEPNetworkSegmentId | Creates a default invalid segment id on the network. |
![]() | MEPNetworkSegmentId(ElementId, Int32) | Creates a valid segment id on the network. |

Name | Description | |
---|---|---|
![]() | ElementId | The element id where this analytical segment belongs. |
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. |
![]() | SegmentId | The segment identifier. |

Name | Description | |
---|---|---|
![]() | Dispose | Releases all resources used by the MEPNetworkSegmentId |
![]() | IsValid | Verifies if this is a valid segment id. |