MEPNetworkSegmentId Class


MEPNetwork Segment Id Class

Represents a unique identifier for one analytical segment in the network.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.Analysis MEPNetworkSegmentId

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class MEPNetworkSegmentId : IDisposable

The MEPNetworkSegmentId type exposes the following members.

Constructors
Name Description
Public method MEPNetworkSegmentId Creates a default invalid segment id on the network.
Public method MEPNetworkSegmentId(ElementId, Int32) Creates a valid segment id on the network.
Top
Properties
Name Description
Public property ElementId The element id where this analytical segment belongs.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property SegmentId The segment identifier.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the MEPNetworkSegmentId
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method IsValid Verifies if this is a valid segment id.
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
See Also