FormulaManager Class


Formula Manager Class

A class to access and query information about formula engine in Revit models.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB FormulaManager

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class FormulaManager : IDisposable

The FormulaManager type exposes the following members.

Properties
Name Description
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the FormulaManager
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method Static member Evaluate Evaluates value of the formula
Public method Static member GetFunctions Gets list of function names supported by formula engine
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method Static member GetOperators Gets list of operator names supported by formula engine
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Public method Static member Validate Validates the formuls
Top
Remarks
Formula manager
See Also