Formula |
A class to access and query information about formula engine in Revit models.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The FormulaManager type exposes the following members.

Name | Description | |
---|---|---|
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. |

Name | Description | |
---|---|---|
![]() | Dispose | Releases all resources used by the FormulaManager |
![]() ![]() | Evaluate | Evaluates value of the formula |
![]() ![]() | GetFunctions | Gets list of function names supported by formula engine |
![]() ![]() | GetOperators | Gets list of operator names supported by formula engine |
![]() ![]() | Validate | Validates the formuls |

Formula manager