Formula |
A class to access and query information about formula engine in Revit models.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The FormulaManager type exposes the following members.

Name | Description | |
---|---|---|
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. |

Name | Description | |
---|---|---|
![]() | Dispose | Releases all resources used by the FormulaManager |
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object ) |
![]() ![]() | Evaluate | Evaluates value of the formula |
![]() ![]() | GetFunctions | Gets list of function names supported by formula engine |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object ) |
![]() ![]() | GetOperators | Gets list of operator names supported by formula engine |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object ) |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object ) |
![]() ![]() | Validate | Validates the formuls |

Formula manager