InitialIlluminanceIntensity Class


Initial Illuminance Intensity Class

This class encapsulates initial illuminance intensity calculation.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.Lighting InitialIntensity
Autodesk.Revit.DB.Lighting InitialIlluminanceIntensity

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class InitialIlluminanceIntensity : InitialIntensity

The InitialIlluminanceIntensity type exposes the following members.

Constructors
Name Description
Public method InitialIlluminanceIntensity(InitialIlluminanceIntensity) Creates a copy of the given initial illuminance intensity object
Public method InitialIlluminanceIntensity(Double, Double) Creates an initial illuminance intensity object with the given document and illuminance values.
Top
Properties
Name Description
Public property Distance The illuminance intensity distance value.
Public property Illuminance The illuminance intensity value.
Public property InitialIntensityValue The calculated initial intensity value.
(Inherited from InitialIntensity )
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from InitialIntensity )
Top
Methods
Name Description
Public method Clone Creates a copy of the InitialIntensity derived object.
(Inherited from InitialIntensity )
Public method Dispose
(Inherited from InitialIntensity )
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
See Also