InitialIlluminanceIntensity Class


Initial Illuminance Intensity Class

This class encapsulates initial illuminance intensity calculation.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.Lighting InitialIntensity
Autodesk.Revit.DB.Lighting InitialIlluminanceIntensity

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class InitialIlluminanceIntensity : InitialIntensity

The InitialIlluminanceIntensity type exposes the following members.

Constructors
Name Description
Public method InitialIlluminanceIntensity(InitialIlluminanceIntensity) Creates a copy of the given initial illuminance intensity object
Public method InitialIlluminanceIntensity(Double, Double) Creates an initial illuminance intensity object with the given document and illuminance values.
Top
Properties
Name Description
Public property Distance The illuminance intensity distance value.
Public property Illuminance The illuminance intensity value.
Top
Methods
Name Description
Top
See Also