Initial |
This class encapsulates initial illuminance intensity calculation.

System Object
Autodesk.Revit.DB.Lighting InitialIntensity
Autodesk.Revit.DB.Lighting InitialIlluminanceIntensity
Autodesk.Revit.DB.Lighting InitialIntensity
Autodesk.Revit.DB.Lighting InitialIlluminanceIntensity
Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The InitialIlluminanceIntensity type exposes the following members.

Name | Description | |
---|---|---|
![]() | InitialIlluminanceIntensity(InitialIlluminanceIntensity) | Creates a copy of the given initial illuminance intensity object |
![]() | InitialIlluminanceIntensity(Double, Double) | Creates an initial illuminance intensity object with the given document and illuminance values. |

Name | Description | |
---|---|---|
![]() | Distance | The illuminance intensity distance value. |
![]() | Illuminance | The illuminance intensity value. |
![]() | InitialIntensityValue | The calculated initial intensity value. (Inherited from InitialIntensity ) |
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from InitialIntensity ) |

Name | Description | |
---|---|---|
![]() | Clone | Creates a copy of the InitialIntensity derived object. (Inherited from InitialIntensity ) |
![]() | Dispose | (Inherited from InitialIntensity ) |
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object ) |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object ) |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object ) |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object ) |