LineSegment Class


Line Segment Class

An output node that represents a tessellated line segment.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB LineSegment

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class LineSegment : IDisposable

The LineSegment type exposes the following members.

Properties
Name Description
Public property EndParameter Parameter associated with the end point.
Public property EndPoint End point of the line segment.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property LineProperties Access to the line (pen) properties of the line
Public property StartParameter Parameter associated with the start point.
Public property StartPoint Start point of the line segment.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the LineSegment
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
Remarks
See also: [!:Autodesk::Revit::DB::IModelExportContext::OnLineSegment] .
See Also