Geometry Property


Element Geometry Property

Retrieves the geometric representation of the element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public GeometryElement this[
	Options options
] { get; }

Parameters

options Options
User preferences for parsing of geometry.

Property Value

GeometryElement
An object that provides access to the geometry of the element.
Remarks

This call will retrieve 3d representation of the element. will be returned for symbols, annotations or details. This involves extensive parsing or Revit's data structures, so try to minimize calls if performance is critical.

Geometry objects provided from this method are obtained directly from the element. When the element is changed for any reason, the geometry will be recalculated by Revit and geometry objects obtained before the change are likely to no longer be valid. If you need to preserve geometry information obtained an element even after changes to that element, you should copy the geometry objects or save the properties independently.

Although the geometry obtained from this method comes directly from the element, any attempt to modify any of the geometry objects will operate only on a disconnected copy of the original geometry object from the element. The modification will not affect the geometry of the original element from which it was obtained - to change the geometry of the element you must use methods that directly affect the geometry calculated or stored by Revit for this element.

If you require that the geometry items obtained contain valid Reference objects , be sure to set the ComputeReferences property of the Options.

See Also