GetSplittingCurves Method (Document, ElementId)


Part Utils Get Splitting Curves(Document, Element Id) Method

Identifies the curves that were used to create the part.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public static IList<Curve> GetSplittingCurves(
	Document document,
	ElementId partId
)

Parameters

document Document
The source document of the part.
partId ElementId
The part id.

Return Value

IList Curve
The curves that created the part. Empty if partId is not a Part or Part is not divided.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
See Also