Part |
Identifies the curves that were used to create the part.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
Return Value
IList CurveThe curves that created the part. Empty if partId is not a Part or Part is not divided.

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |

public void GetCurveDividers(Part part)
{
StringBuilder message = new StringBuilder();
// Get curve dividers.
IList<Curve> divisionCurves = PartUtils.GetSplittingCurves(part.Document, part.Id);
if (divisionCurves.Count == 0)
message.AppendLine("Part is not divided.");
else
{
message.AppendLine("The dividers are : ");
if (divisionCurves.Count > 0)
message.AppendLine(divisionCurves.Count.ToString() + " division curves");
}
TaskDialog.Show("Revit", message.ToString());
}