RebarRoundingManager Class


Rebar Rounding Manager Class

Provides access to element reinforcement roundings overrides.
Inheritance Hierarchy

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class RebarRoundingManager : ReinforcementRoundingManager

The RebarRoundingManager type exposes the following members.

Properties
Name Description
Public property ApplicableReinforcementRoundingSource Identifies the source of the rounding settings for this element.
Public property ApplicableSegmentLengthRounding The applicable rounding for shared parameters used by rebar.
Public property ApplicableSegmentLengthRoundingMethod The applicable rounding method for shared parameters used by rebar.
Public property ApplicableTotalLengthRounding The applicable rounding for Bar Length and Total Bar Length parameters.
Public property ApplicableTotalLengthRoundingMethod The applicable rounding method for Bar Length and Total Bar Length parameters.
Public property Element The owner of the reinforcement rounding overrides.
(Inherited from ReinforcementRoundingManager )
Public property IsActiveOnElement Defines whether reinforcement rounding is activated for the particular element.
(Inherited from ReinforcementRoundingManager )
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from ReinforcementRoundingManager )
Public property SegmentLengthRounding The rounding for shared parameters used by rebar.
Public property SegmentLengthRoundingMethod Identifies the segment length rounding method
Public property TotalLengthRounding The rounding for Bar Length and Total Bar Length parameters.
Public property TotalLengthRoundingMethod Identifies the total length rounding method
Top
Methods
Name Description
Public method Dispose
(Inherited from ReinforcementRoundingManager )
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetLengthUnitTypeId Gets the identifier of the length unit quantifying the reinforcement rounding values.
(Inherited from ReinforcementRoundingManager )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
Remarks
An instance of this class can be obtained from specific RebarTypes or individual Rebar or RebarInSystem elements to apply overrides different from the global settings for the project.
See Also