RebarRoundingManager Class


Rebar Rounding Manager Class

Provides access to element reinforcement roundings overrides.
Inheritance Hierarchy

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class RebarRoundingManager : ReinforcementRoundingManager

The RebarRoundingManager type exposes the following members.

Properties
Name Description
Public property ApplicableReinforcementRoundingSource Identifies the source of the rounding settings for this element.
Public property ApplicableSegmentLengthRounding The applicable rounding for shared parameters used by rebar.
Public property ApplicableSegmentLengthRoundingMethod The applicable rounding method for shared parameters used by rebar.
Public property ApplicableTotalLengthRounding The applicable rounding for Bar Length and Total Bar Length parameters.
Public property ApplicableTotalLengthRoundingMethod The applicable rounding method for Bar Length and Total Bar Length parameters.
Public property SegmentLengthRounding The rounding for shared parameters used by rebar.
Public property SegmentLengthRoundingMethod Identifies the segment length rounding method
Public property TotalLengthRounding The rounding for Bar Length and Total Bar Length parameters.
Public property TotalLengthRoundingMethod Identifies the total length rounding method
Top
Methods
Name Description
Top
Remarks
An instance of this class can be obtained from specific RebarTypes or individual Rebar or RebarInSystem elements to apply overrides different from the global settings for the project.
See Also