Rebar |
Provides access to element reinforcement roundings overrides.

System Object
Autodesk.Revit.DB.Structure ReinforcementRoundingManager
Autodesk.Revit.DB.Structure RebarRoundingManager
Autodesk.Revit.DB.Structure ReinforcementRoundingManager
Autodesk.Revit.DB.Structure RebarRoundingManager
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The RebarRoundingManager type exposes the following members.

Name | Description | |
---|---|---|
![]() | ApplicableReinforcementRoundingSource | Identifies the source of the rounding settings for this element. |
![]() | ApplicableSegmentLengthRounding | The applicable rounding for shared parameters used by rebar. |
![]() | ApplicableSegmentLengthRoundingMethod | The applicable rounding method for shared parameters used by rebar. |
![]() | ApplicableTotalLengthRounding | The applicable rounding for Bar Length and Total Bar Length parameters. |
![]() | ApplicableTotalLengthRoundingMethod | The applicable rounding method for Bar Length and Total Bar Length parameters. |
![]() | Element | The owner of the reinforcement rounding overrides. (Inherited from ReinforcementRoundingManager ) |
![]() | IsActiveOnElement | Defines whether reinforcement rounding is activated for the particular element. (Inherited from ReinforcementRoundingManager ) |
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from ReinforcementRoundingManager ) |
![]() | SegmentLengthRounding | The rounding for shared parameters used by rebar. |
![]() | SegmentLengthRoundingMethod | Identifies the segment length rounding method |
![]() | TotalLengthRounding | The rounding for Bar Length and Total Bar Length parameters. |
![]() | TotalLengthRoundingMethod | Identifies the total length rounding method |

Name | Description | |
---|---|---|
![]() | Dispose | (Inherited from ReinforcementRoundingManager ) |
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object ) |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object ) |
![]() | GetLengthUnitTypeId | Gets the identifier of the length unit quantifying the reinforcement rounding values. (Inherited from ReinforcementRoundingManager ) |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object ) |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object ) |

An instance of this class can be obtained from specific RebarTypes or individual Rebar or RebarInSystem elements to apply overrides different from the global settings for the project.