Rebar |
Provides access to element reinforcement roundings overrides.

System Object
Autodesk.Revit.DB.Structure ReinforcementRoundingManager
Autodesk.Revit.DB.Structure RebarRoundingManager
Autodesk.Revit.DB.Structure ReinforcementRoundingManager
Autodesk.Revit.DB.Structure RebarRoundingManager
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The RebarRoundingManager type exposes the following members.

Name | Description | |
---|---|---|
![]() | ApplicableReinforcementRoundingSource | Identifies the source of the rounding settings for this element. |
![]() | ApplicableSegmentLengthRounding | The applicable rounding for shared parameters used by rebar. |
![]() | ApplicableSegmentLengthRoundingMethod | The applicable rounding method for shared parameters used by rebar. |
![]() | ApplicableTotalLengthRounding | The applicable rounding for Bar Length and Total Bar Length parameters. |
![]() | ApplicableTotalLengthRoundingMethod | The applicable rounding method for Bar Length and Total Bar Length parameters. |
![]() | SegmentLengthRounding | The rounding for shared parameters used by rebar. |
![]() | SegmentLengthRoundingMethod | Identifies the segment length rounding method |
![]() | TotalLengthRounding | The rounding for Bar Length and Total Bar Length parameters. |
![]() | TotalLengthRoundingMethod | Identifies the total length rounding method |

Name | Description | |
---|---|---|

An instance of this class can be obtained from specific RebarTypes or individual Rebar or RebarInSystem elements to apply overrides different from the global settings for the project.