PointRelativeToPoint Class


Point Relative To Point Class

Represents a point placed relative to another point.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB PointElementReference
Autodesk.Revit.DB PointRelativeToPoint

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class PointRelativeToPoint : PointElementReference

The PointRelativeToPoint type exposes the following members.

Methods
Name Description
Public method GetHostPointReference Get a copy of the host point reference.
Public method SetHostPointReference Change the host point reference.
Top
Remarks
For this release, the only workflow supported is that the point is placed coincident with the referenced host (a relative transformation of Transform.Identity).
See Also