FamilySizeTableManager Class


Family Size Table Manager Class

Manages importing, exporting, and querying size data through the FamilySizeTable class.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB FamilySizeTableManager

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class FamilySizeTableManager : IDisposable

The FamilySizeTableManager type exposes the following members.

Properties
Name Description
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property NumberOfSizeTables The number of FamilySizeTables in a family.
Top
Methods
Name Description
Public method Static member CreateFamilySizeTableManager Adds FamilySizeTableManager to a Family. A FamilySizeTableManager and FamilySizeTables are only needed when importing, exporting, or removing size data previously stored in CSV files.
Public method Dispose Releases all resources used by the FamilySizeTableManager
Public method ExportSizeTable Exports the size table to aCSV file.
Public method GetAllSizeTableNames Get the FamilySizeTable names in a family.
Public method Static member GetFamilySizeTableManager Gets a FamilySizeTableManager from a Family
Public method GetSizeTable Get a FamilySizeTable by name.
Public method HasSizeTable Checks if a FamilySizeTable of a given name exists.
Public method ImportSizeTable Imports a FamilySizeTable from a CSV file.
Public method RemoveSizeTable Removes the FamilySizeTable of a given name.
Top
See Also