Rebar |
The class that contains data for the handle position calculation.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The RebarHandlePositionData type exposes the following members.

Name | Description | |
---|---|---|
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. |

Name | Description | |
---|---|---|
![]() | Dispose | Releases all resources used by the RebarHandlePositionData |
![]() | GetBarGeometry | Returns the geometry for a bar at the specified index currently in the Rebar. |
![]() | GetDistributionPath | Gets the distribution path currently stored in the rebar. |
![]() | GetNumberOfBars | Gets the number of bars currently in the rebar. |
![]() | SetPosition | Sets the position for a specified handle. This information is set to the rebar after the API execution is finished successfully. |