RebarHandlePositionData Class


Rebar Handle Position Data Class

The class that contains data for the handle position calculation.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.Structure RebarHandlePositionData

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class RebarHandlePositionData : IDisposable

The RebarHandlePositionData type exposes the following members.

Properties
Name Description
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the RebarHandlePositionData
Public method GetBarGeometry Returns the geometry for a bar at the specified index currently in the Rebar.
Public method GetDistributionPath Gets the distribution path currently stored in the rebar.
Public method GetNumberOfBars Gets the number of bars currently in the rebar.
Public method SetPosition Sets the position for a specified handle. This information is set to the rebar after the API execution is finished successfully.
Top
See Also