IFCFile Read(IFCFile |
Reads content from a file of IFC format.
Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- readOptions IFCFileReadOptions
- The IFC file read options.

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |
InvalidOperationException | Error reading opening model for unzipping. Error reading IFC file. |