Read Method (IFCFileReadOptions)


IFCFile Read(IFCFile Read Options) Method

Reads content from a file of IFC format.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void Read(
	IFCFileReadOptions readOptions
)

Parameters

readOptions IFCFileReadOptions
The IFC file read options.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
InvalidOperationException Error reading opening model for unzipping. Error reading IFC file.
See Also