InsertRow Method


Table Section Data Insert Row Method

Inserts a row data at a specified index.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public void InsertRow(
	int nIndex
)

Parameters

nIndex Int32
An integer index.
Exceptions
Exception Condition
ArgumentException The row can't be inserted in data section of standard schedule except Key Schedule, Sheet List Schedule or following categories without emdeded schedule: MEP Space, Room, Area. or nIndex is invalid index.
See Also