InsertRow Method


Table Section Data Insert Row Method

Inserts a row data at a specified index.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void InsertRow(
	int nIndex
)

Parameters

nIndex Int32
An integer index.
Exceptions
Exception Condition
ArgumentException The row can't be inserted in data section of standard schedule except Key Schedule, Sheet List Schedule or following categories without emdeded schedule: MEP Space, Room, Area. or nIndex is invalid index.
Example
public void CreateSubtitle(ViewSchedule schedule)
{
    TableData colTableData = schedule.GetTableData();

    TableSectionData tsd = colTableData.GetSectionData(SectionType.Header);
    tsd.InsertRow(tsd.FirstRowNumber + 1);
    tsd.SetCellText(tsd.FirstRowNumber + 1, tsd.FirstColumnNumber, "Schedule of column top and base levels with offsets");
}
See Also