View |
Verifies that boundary represents one closed curve loop without self-intersections, consisting of non-zero length straight lines in a plane parallel to the view plane.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- boundary CurveLoop
- The crop boundary.
Return Value
BooleanTrue if the passed crop boundary represents one closed curve loop without self-intersections, consisting of non-zero length straight lines in a plane parallel to the view plane.

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |

Curves in boundary use model coordinates.