IsCropRegionShapeValid Method


View Crop Region Shape Manager Is Crop Region Shape Valid Method

Verifies that boundary represents one closed curve loop without self-intersections, consisting of non-zero length straight lines in a plane parallel to the view plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public bool IsCropRegionShapeValid(
	CurveLoop boundary
)

Parameters

boundary CurveLoop
The crop boundary.

Return Value

Boolean
True if the passed crop boundary represents one closed curve loop without self-intersections, consisting of non-zero length straight lines in a plane parallel to the view plane.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
Remarks
Curves in boundary use model coordinates.
See Also