IndexStreamTriangle Class


Index Stream Triangle Class

A stream that can be used to write IndexTriangle primitives into an IndexBuffer
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.DirectContext3D IndexStream
Autodesk.Revit.DB.DirectContext3D IndexStreamTriangle

Namespace: Autodesk.Revit.DB.DirectContext3D
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class IndexStreamTriangle : IndexStream

The IndexStreamTriangle type exposes the following members.

Properties
Name Description
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from IndexStream )
Top
Methods
Name Description
Public method AddTriangle Inserts a IndexTriangle into the stream and associated buffer.
Public method AddTriangles
Public method Dispose
(Inherited from IndexStream )
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
See Also