IndexStreamTriangle Class


Index Stream Triangle Class

A stream that can be used to write IndexTriangle primitives into an IndexBuffer
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.DirectContext3D IndexStream
Autodesk.Revit.DB.DirectContext3D IndexStreamTriangle

Namespace: Autodesk.Revit.DB.DirectContext3D
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class IndexStreamTriangle : IndexStream

The IndexStreamTriangle type exposes the following members.

Properties
Name Description
Top
Methods
Name Description
Public method AddTriangle Inserts a IndexTriangle into the stream and associated buffer.
Public method AddTriangles
Top
See Also